Manual do Usuário do Conversor SPERO

Manual do Usuário do Conversor - ÍNDICE
Introdução |  |  | Versão 0.99e
Versões Disponíveis
Contrato de Licença de Uso
Novidades desta Versão
Instalação do Conversor Spero
Utilização do Conversor Spero
 | Comandos da janela principal
 | O diálogo de configuração da conversão
 |  | Configuração da formatação
 |  | Seleção dos mercados a converter
 |  | Seleção das etapas de processamento
 |  | Descrição detalhada
 |  | Miscelânea - Outras Opções
Futuros Melhoramentos Idealizados
Problemas Conhecidos do Conversor Spero |  |  |
Considerações Finais e Histórico das Versões |  |  |
Transferência do Arquivo de Instalação |  |  |
Introdução

© 1998-2000 André Viol. Todos os direitos reservados.


Convertendo de ASCII para MetaStock

Guia de Conversão dos arquivos ASCII

Trabalhando com os Arquivos ASCII

Conteúdo

  • Conteúdo dos arquivos ASCII
  • Configurando o programa The Downloader
  • Convertendo os arquivos ASCII
  • Comentários finais

Os arquivos gerados pelo Conversor Spero encontram-se em um formato denominado ASCII Text e devem ser convertidos para o formato do programa MetaStock, também chamado de formato MetaStock, a fim de atualizar a pasta de cotações das ações da BOVESPA. Para isto, deve ser utilizado o programa The Downloader, o qual acompanha o programa MetaStock.

Neste tutorial, irei explicar, em detalhes, o conteúdo dos arquivos ASCII e como fazer, passo a passo, a sua conversão manual para o formato MetaStock.

Início

Conteúdo dos Arquivos ASCII

Os arquivos BDI que a BOVESPA disponibiliza diariamente no seu site (http://www.bovespa.com.br) trazem uma infinidade de informações sobre o que aconteceu no pregão da BOVESPA (quem quiser conhecer em detalhes o BDI basta transferir o layout do arquivo que está disponível na página de cotações do site da BOVESPA); entre as informações do BDI há as cotações de diversos mercados de papéis: do lote padrão; a termo; de concordatárias; de direitos e recibos; de bônus privados; de apólices, bônus e títulos públicos; de opções de compra e de venda; de exercícios de opções de compra e de venda; de fundos e certificados; de debêntures; do mercado fracionário, entre outros menos comuns. Os arquivos ASCII gerados pelo conversor Spero tratam, individualmente, os seguintes mercados:

  • Lote Padrão.
  • Concordatárias.
  • Direitos e Recibos.
  • Bônus Privados.
  • Fundos e Certificados.
  • Termo.
  • Opções de Compra.
  • Opções de Venda.
  • Fracionário.

Para estes mercados, os arquivos ASCII contêm todos os códigos dos papéis que tiveram volume negociado maior do que zero. Além dos mercados acima, os arquivos ASCII contêm os dados diários dos índices BOVESPA - Ibovespa - de energia elétrica - IEE - e Brasil - IBX.

As informações, para cada papel, contidas nos arquivos ASCII são:

  • Ticker, ou o código do papel.
  • Data do pregão.
  • Cotação de abertura.
  • Cotação máxima.
  • Cotação mínima.
  • Cotação de fechamento.
  • Volume.

Além das informações acima, os arquivos ASCII têm um campo opcional, denominado Open Interest, o qual é utilizado, por alguns fornecedores de dados, para repassar ao MetaStock outras informações. Maiores detalhes de como o conversor Spero pode utilizar este campo você encontra no Manual do Usuário do conversor.

No caso do ticker, para a geração dos arquivos ASCII, há a opção de se utilizar um código diferente do oficial dado pela BOVESPA ao papel, aqui chamado de formato "proprietário do Spero". Idealmente deveria ser utilizado, no formato MetaStock, o código oficial como o código do papel e o nome da empresa ou ação como o nome do papel. O formato MetaStock aceita as duas informações: symbol (código) e name (nome). Entretanto, o programa conversor The Downloader não aceita repassar estas duas informações, do formato ASCII para o formato MetaStock; o formato ASCII aceita apenas a informação do ticker que, ao ser levada para o formato MetaStock, torna-se tanto o symbol como o name do papel. Esta é uma limitação do formato ASCII utilizado pelo Downloader. Assim, uma vez que não é possível diferenciar, via conversão, o symbol do name, e é difícil reconhecer muitos papéis apenas pelo seu código oficial, foi criada uma regra de geração dos tickers que mistura o nome da empresa/ação com o código do papel. O tamanho final do ticker assim criado está limitado ao máximo de 14 caracteres, limitação esta da informação de symbol do formato MetaStock (a informação de name aceita uma quantidade maior de caracteres).

É interessante saber que o Downloader não altera o valor do name, ao atualizar as cotações, se (a) o papel já existir no diretório de cotações e (b) se o name existente for diferente do valor do ticker repassado pelo arquivo intermediário (arquivo ASCII) gerado pelo conversor. O Downloader repassa o valor do ticker para o name apenas quando ele cria, do zero, um novo papel no diretório de cotações. Portanto, se o usuário do MetaStock/Downloader quiser, utilizando o Downloader, dar um name diferente para seus papéis (isso deve ser feito um a um, via Downloader) do valor do ticker originalmente criado, não haverá problema pois este novo valor de name não será, futuramente, alterado pelas atualizações do Downloader, com base nos arquivos ASCII gerados pelo conversor. O valor de name pode ter bem mais do que apenas 14 caracteres e pode descrever melhor o papel.

As regras de criação dos tickers, quando optado pelo formato proprietário, dos arquivos ASCII gerados pelo Spero, são as seguintes:

  • o código oficial do papel, que possui de 4 a 8 caracteres, ocupa os caracteres finais do ticker, sem qualquer alteração.
  • os caracteres iniciais do ticker contêm, dentro da limitação de 14 caracteres, o que for possível informar sobre o nome da empresa/ação.
  • entre a primeira parte do ticker (o que couber do nome da empresa/ação) e a segunda (o código oficial do papel) é colocado, como separador, o sinal de sublinhado "_".
  • se o nome da empresa/ação contiver brancos eles são eliminados antes de fazer parte do início do ticker.
  • se o papel não pertencer ao lote padrão é acrescentado um mnemônico do tipo de papel na primeira letra do ticker, a saber: c_ para as Concordatárias, r_ para os Direitos e Recibos, u_ para os Fundos e Certificados, b_ para os Bônus Privados, o_ para as Opções de Compra, v_ para as Opções de Venda e f_ para o mercado Fracionário. Para o mercado a Termo, utiliza-se o mnemônico tx, onde x é um número que "lembra" o prazo do papel; exemplos: para prazo de 30 dias, "x" é igual a 3; prazo de 60 dias, "x" é igual a 6; 90 dias, "x" igual a 9; e, 120 dias, "x" é igual a 2.

No caso de optar pelo código oficial da Bovespa, apenas no caso do mercado a Termo, haverá uma alteração no código, ao repassá-lo para o arquivo intermediário: serão acrescentados, ao final do código oficial, dois ou três dígitos que equivalem ao prazo do papel, para diferenciar papéis da mesma empresa porém com prazos diferentes.

Os demais dados contidos nos arquivos ASCII, como as cotações de abertura, fechamento, máxima e mínima são auto explicativos. Com relação aos dados de volume, eles podem corresponder tanto aos valores totais negociados em reais como às quantidades totais de ações negociadas, do respectivo papel, dependendo da configuração do usuário.

Abaixo segue um extrato de um arquivo ASCII onde podem ser observados exemplos de tickers criados conforme as regras acima.

<TICKER>,<PER>,<DTYYMMDD>,<TIME>,<OPEN>,<HIGH>,<LOW>,<CLOSE>,<VOL>,<O/I>
IBOVESPA,D,980403,0,11854,11855,11493,11634,859177208,0
IEE,D,980403,0,2901,2906,2832,2846,55160509,0
IBX,D,980403,0,2328,2330,2270,2286,889846800,0
ACESITA_ACES3,D,980403,0,2.01,2.12,1.98,2.05,2105619,0
BELGOMIN_BELG4,D,980403,0,73.00,73.00,70.00,72.00,340096,0
CIMBRASI_SPCI4,D,980403,0,1.85,1.85,1.85,1.85,44400,0
FCATAGUA_FLCL5,D,980403,0,2.20,2.25,2.20,2.23,71493,0
LIGHTPAR_LIPR3,D,980403,0,301.00,304.00,298.00,302.00,2608086,0
SABESP_SBSP3,D,980403,0,260.00,265.00,260.00,260.00,2710236,0
SADIACON_SCON4,D,980403,0,0.84,0.85,0.83,0.85,1531560,0
TELEBRAS_TELB4,D,980403,0,143.00,143.30,138.52,141.50,526200324,0
r_TELEB_TELB10,D,980403,0,143.00,147.00,139.00,147.00,3293292,0
b_BRASI_BBAS11,D,980403,0,3.60,3.75,3.25,3.40,806984,0
o_TELE_TELBD59,D,980403,0,46.51,46.51,42.21,42.21,4310000,0

O formato do arquivo ASCII segue as instruções contidas na Ajuda do programa The Downloader. Se alguém quiser conhecer maiores detalhes sobre o formato, procure pelo tema ASCII Source File Layout, no conteúdo da Ajuda online do programa ou por ASCII: converting data, no índice da Ajuda do Downloader.

Nota Importante O conteúdo dos arquivos ASCII, conforme descrito neste tópico, pode sofrer alterações em função da personalização das opções de conversão selecionadas pelo usuário do conversor Spero, no diálogo de "Configuração da Conversão". Para maiores detalhes, após ler este Guia, consulte o Manual do Usuário do Conversor.

Início

Configurando o Programa The Downloader

Antes de converter os arquivos ASCII para o formato MetaStock, você precisa configurar adequadamente as opções de conversão do Downloader. Esta configuração deve ser feita uma única vez. Mesmo que você vá utilizar o acionamento remoto do Downloader, via conversor, é importante que, antes, você compreenda o processo de conversão e selecione as opções de conversão disponíveis no Downloader.

Primeiramente, execute o programa The Downloader. Ele pode ser executado a partir do seu ícone próprio ou de dentro do MetaStock.

Nota As figuras aqui mostradas referem-se à versão 6.0 do Downloader; entretanto, as diferenças em relação às versões mais modernas (por exemplo, a 6.52) são tão pequenas que é possível seguir este guia sem dificultar a compreensão.

Já com o Downloader aberto, chame o diálogo de conversão Convert Securities. Você pode chamá-lo clicando no botão Convert, na barra de ferramentas (Toolbar), ou clicando no menu Tools e depois selecionando a opção Convert... .

Acionando a conversão

Deve aparecer um diálogo igual ao mostrado abaixo. As caixas de texto e as caixas de opções podem estar pré-preenchidas de forma diferente; você aprenderá como configurá-las no próximo tópico.

Diálogo de conversão

No diálogo Convert Securities, clique no botão Options... para chamar o diálogo de opções de conversão Conversion Options. Ele está mostrado abaixo.

Opções dos arquivos origem

O diálogo Conversion Options tem duas fichas: Source e Destination. Clique na aba da ficha Source, caso ela já não esteja ativa

Na ficha Source, certifique-se de que a caixa First date: tenha uma data digitada nela (teoricamente, a data da ação mais antiga do seu diretório de ações; pode ser qualquer data anterior a essa também); certifique-se de que Use today's date esteja selecionado e que a Periodicity esteja selecionada como Dayly; Traverse source folders NÃO deve estar selecionado; é indiferente o que estiver constando em Message Limits assim como em Minutes per bar:, que provavelmente deve estar "acinzentado", ou seja, desabilitado, não selecionável.

Clique na aba da ficha Destination para ativá-la.

Opções dos arquivos destino

Nesta ficha, certifique-se de que Append data to end of file, Replace matching dates e Create new files estejam todos selecionados; Traverse destination folders NÃO deve estar selecionado; as opções de Fields to output são indiferentes (provavelmente devem estar "acinzentadas", ou seja, desabilitadas).

Com relação à opção Include Open & Open Interest, fica a seu critério selecioná-la ou não. Caso ela seja selecionada as informações de cotações de abertura dos papéis serão incluídas na base de dados em formato MetaStock; caso contrário, obviamente que não. Você somente teria motivo para não incluir as informações de abertura se pretender trabalhar com índices ou linhas de estudo que não necessitem delas. Normalmente, até mesmo por precaução quanto ao que você pode querer no futuro, deixe esta opção ticada.

Clique no botão OK para sair do diálogo Conversion Options e retornar ao diálogo Convert Securities. Clique no botão Cancel e saia deste último diálogo, ou passe para o próximo tópico para efetuar a sua primeira conversão.

Nota Mesmo que você opte por clicar no botão Cancel, após ter seguido todos os passos acima, você não estará cancelando as opções de conversão; elas já foram gravadas pelo Downloader no momento em que você clicou OK para sair do diálogo Conversion Options. Se estas opções não forem posteriormente alteradas manualmente, não será mais preciso se preocupar pois elas não se alteram por si só.

Início

Convertendo os Arquivos ASCII

Para prosseguir com o este tutorial, precisamos fazer algumas suposições: vamos supor que você tenha uma pasta de trabalho (diretório, para os saudosistas) chamada Ibovespa, ligada ao seu diretório raiz do drive C:\; vamos supor que esta pasta Ibovespa tenha duas pastas ligadas a ela (subdiretórios) denominadas PRNs e DATs. A pasta PRNs terá por objetivo armazenar os arquivos ASCII que você gerou utilizando o conversor Spero; a pasta DATs será a pasta com as cotações da BOVESPA já convertidas para o formato MetaStock, ou seja, o diretório de cotações. A nossa suposta árvore de diretórios fica mais ou menos assim, no painel esquerdo do Windows Explorer:

Árvore de pastas

Nota Importante Os nomes para as pastas de trabalho aqui sugeridos são meramente exemplificativos e servem apenas para explicar o processo manual de conversão do arquivo ASCII para o formato MetaStock. Ao utilizar o conversor Spero para automatizar o processo, você não terá a opção de escolher alguns dos nomes destes diretórios pois eles estarão estritamente ligados ao diretório onde o conversor foi instalado que é chamado de diretório de trabalho. Veja maiores detalhes no manual do conversor.

Coloque os arquivos ASCII gerados pelos conversor, na pasta C:\Ibovespa\PRNs\. Você pode colocar um ou vários arquivos ao mesmo tempo. O arquivo intermediário ASCII, que você colocou na pasta C:\Ibovespa\PRNs\ deve ter a extensão .PRN, ou seja, deve ter a seguinte estrutura de nome: Bdinmmdd.PRN, onde Bdin é um prefixo constante, mm significa o mês de referência e dd, o dia do mês.

Com as opções de conversão do Downloader já corretamente configuradas e os arquivos ASCII, gerados pelo conversor, já no diretório mencionado, para dar início ao processo de conversão acione novamente o diálogo de conversão do Downloader, Convert Securities, caso ele já não esteja ativo.

Diálogo de conversão

O diálogo de conversão possui dois grupos de informações: o grupo superior, denominado Source, e o inferior, denominado Destination. Ambos contêm exatamente as mesmas informações: tipo de arquivo (File type:), pasta ou diretório (Folder:), nome do arquivo (File name:) e um botão Procurar (Browse...). No primeiro grupo você preencherá as informações relativas aos arquivos de origem, ou arquivos fonte, no caso os arquivos ASCII gerados pelo conversor; o segundo grupo serve para você passar ao Downloader as informações dos arquivos de destino, no nosso caso, os arquivos em formato MetaStock.

No grupo Source, selecione, na caixa de opções File type:, o tipo ASCII Text. Clique no botão Browse... para acionar o diálogo de escolha dos arquivos de origem, Choose Source Files:

Diálogo de escolha do ASCII

No diálogo Choose Source Files utilize a caixa de opções Examinar e direcione o foco do diálogo para o diretório C:\Ibovespa\PRNs\, onde encontram-se os arquivos ASCII; utilize a caixa de opções Arquivos do tipo: para selecionar o tipo ASCII Files (*.PRN), conforme mostrado na figura acima.

Uma vez enxergando os arquivos ASCII no quadro central do diálogo, selecione o arquivo ASCII que deseja converter; você pode também, utilizando as teclas Shift ou Control, ao mesmo tempo em que clica com o botão do mouse, fazer escolhas múltiplas, ou seja, de conversão de vários arquivos ASCII no mesmo processo, ao mesmo tempo.

Tendo selecionado os arquivos ASCII de interesse, seus nomes aparecerão na caixa de texto Nome do arquivo:. Se a escolha foi múltipla, os nomes aparecerão entre aspas. Clique no botão Abrir para sair deste diálogo.

De volta ao Convert Securities, no grupo Destination, selecione, na caixa de opções File type:, o tipo MetaStock. Na caixa de texto Folder: você deve digitar o nome completo da pasta de trabalho onde quer que as ações, já convertidas para o formato MetaStock, sejam armazenadas; em nosso exemplo, você deve digitar C:\Ibovespa\DATs\ . Não se preocupe em diferenciar letras maiúsculas de minúsculas. Se não quiser digitar, clique no botão Browse..., do grupo Destination, para acionar o diálogo de seleção do diretório de destino, Save, utilize a caixa de opções Salvar em:, direcione o foco do diálogo para o diretório C:\Ibovespa\DATs\ e clique no botão Save para sair deste diálogo.

O diálogo Convert Securities deve estar semelhante ao mostrado abaixo:

Diálogo de conversão completado

Pronto! Clique no botão OK e aguarde até que o Downloader faça e termine o seu trabalho. Nesse meio tempo o Downloader apresenta o diálogo de status da conversão, Convert Status.

Status da conversão

A conversão de um arquivo ASCII leva alguns bons segundos, mesmo em computadores mais velozes, pois o Downloader tem de abrir e fechar centenas de arquivos, o que significa trabalho mecânico do disco rígido e contra isso não há Pentium II/III que resolva. A conversão de vários arquivos ASCII, ao mesmo tempo, aumenta proporcionalmente o tempo total de conversão. Se for uma conversão inicial, ou seja, direcionada para um diretório vazio, a conversão será mais lenta que as seguintes pois, nesta primeira conversão, o Downloader precisará não só abrir e fechar centenas de arquivos mas, também, criá-los.

Assim que o Downloader finaliza as conversões, ele apresenta um relatório de conversão, o Conversion Report, que merece alguma atenção.

Relatório final da conversão

O ponto mais importante do relatório é a mensagem que aparece no quadro Status Conversion: DEVE aparecer a mensagem Data Converted And Stored, comprovando que a conversão foi finalizada com absoluto sucesso.

Nota Avançada Se a mensagem acima não aparecer significa que algum erro ocorreu durante a conversão. Foge ao escopo deste tutorial informar o que deve ser feito, caso isto ocorra. Apenas como passo inicial, verifique, no quadro Securities, quais ações tiveram erro durante a conversão; elas terão um X vermelho ou um triângulo amarelo do lado esquerdo do nome, e não o tique verde. Selecione as ações, uma por vez, e clique no botão Details... para ter um relatório do erro. A partir daí, é por sua conta. Afirmo apenas que dificilmente, se ocorrer algum erro, ele será por culpa do arquivo ASCII; mas, por desencargo de consciência, você pode dar uma olhada dentro do arquivo ASCII, utilizando qualquer editor de texto, e verificar se o formato dele está de fato em acordo com as especificações do Downloader.

Com isso finaliza-se a conversão. Clique no botão Close para fechar o relatório de conversão, feche o Downloader, se não for mais utilizá-lo, execute o programa MetaStock e abra as ações, que se encontram na pasta de ações C:\Ibovespa\DATs\, para análise, diversão e ganhar muito dinheiro.

Numa próxima conversão manual, supondo que os arquivos ASCII sejam armazenados sempre na mesma pasta, você não precisaria preencher todo o diálogo de conversão novamente. Ele já estará pré-preenchido com as informações da última conversão realizada e você terá de atualizar apenas o nome do arquivo ASCII.

Início

Comentários Finais

O tutorial acima tentou demonstrar como fazer uma conversão manual de um ou mais arquivos ASCII para o formato MetaStock. Na realidade, utilizando o conversor Spero, é possível - e desejável - automatizar todo o processo, desde a transferência do BDI zipado do site da Bovespa para o seu computador, via Internet, até a conversão final para o formato MetaStock, feita pelo Downloader, passando pela geração do arquivo ASCII Text e, opcionalmente, pelo armazenamento do BDI zipado em um diretório específico. O domínio do conhecimento de uma conversão manual é útil para compreender o que o conversor está fazendo e é necessário para quando você quiser fazer conversões múltiplas, ou seja, de mais de um arquivo ASCII ao mesmo tempo, via Downloader.

Os programas The Downloader e MetaStock têm um limite máximo de armazenamento de 2000 ações, em uma mesma pasta de trabalho. Como os arquivos ASCII gerados pelo conversor contêm informações de vários mercados, entre eles os de opções de compra e venda, há a possibilidade de, ao longo do tempo (um bom tempo...), o limite ser atingido. Por este motivo, você deve ficar atento a esta limitação, caso não efetue limpezas periódicas na pasta de ações. A Equis International, responsável pelo programa MetaStock, recomenda que se trabalhe com, no máximo, mil ações em uma mesma pasta de trabalho, pois, segundo ela, acima deste quantitativo há perda significativa de desempenho.

Agora que você já entendeu o que é e como utilizar um arquivo ASCII gerado pelo conversor Spero, aconselha-se a buscar maiores informações sobre o processo de automatização e funcionamento do conversor e o trabalho conjunto com o programa The DownLoader, no Manual do Usuário do Conversor Spero.

Atualizado em 27 de março de 2000.
André Viol
Retorna

Início

© 2000 André Viol. Todos os direitos reservados.


Ajuste no Cálculo da Quantidade Total de Ações Negociadas

Sobre a inconsistência nos dados relativos à quantidade total de ações negociadas, apresento o raciocínio abaixo para demonstrar que o método usado pela Bovespa no cálculo da quantidade total de ações negociadas gera incorreções.

Suponhamos que apenas 2 ações são negociadas.

A primeira com preço "p1" e quantidade "Q1" negociada em Reais/1000 ações; e a segunda com preço "p2" e quantidade "Q2" negociada em Reais por ação.

A questão que se apresenta é se a quantidade total de ações negociadas Q deve ser representada por:

Q = (Q1+Q2)/1000 ………(1), ou

Q = Q1/1000 + Q2 ………(2)

O primeiro cálculo (1) é o utilizado pela Bovespa. A minha tese, que pretendo demonstrar, é que o correto é a expressão (2).

O volume total em reais, "P" arrecadado com a negociação dessas 2 ações é dado por:

P = p1.Q1/1000 + p2.Q2 ………(3)

Por outro lado, o preço médio das ações negociadas será dado pela divisão de (3) por (1) ou por (2), ou seja:

pm = P/(Q1+Q2)/1000 ………(4), ou

pm = P/(Q1/1000 + Q2) ………(5)

Vejamos o primeiro caso. Substituindo em (4) P pela expressão em (3) e desenvolvendo, tem-se:

pm = (p1.Q1/1000 + p2.Q2)/(Q1+Q2)/1000

que pode ser expressa como:

pm = p1/(1 + Q2/Q1) + 1000.p2/(1 + Q1/Q2) ………(6)

calculando o limite quando Q1 ou Q2 tendem para o infinito,

Q1 ® ¥ => pm = p1

Q2 ® ¥ => pm = 1000.p2, o que é um absurdo!

Vejamos agora o segundo caso:

Substituindo em (5) "P" pela expressão em (3) e desenvolvendo, tem-se:

pm = (p1.Q1/1000 + p2.Q2)/(Q1/1000 + Q2)

que pode ser expressa como:

pm = p1/(1 + 1000.Q2/Q1) + 1000.p2/(1000 + Q1/Q2) ………(7)

calculando o limite quando Q1 ou Q2 tendem para o infinito (¥):

Q1 ® ¥ => pm = p1

Q2 ® ¥ => pm = p2, que é o resultado esperado.

Portanto, o correto é indicar-se a quantidade total de títulos negociados somando-se a quantidade total de ações de cotação unitária negociadas sem divisão por 1000 e a quantidade total de ações de cotação por 1000 ações divida por 1000, ou seja de acordo com a fórmula em (2)

Q = Q1/1000 + Q2

Convém notar que dimensionalmente, isso faz todo sentido. As quantidades Q1 e Q2 podem ser comparadas a medidas em milímetros e metros respectivamente. Para que sua soma faça sentido o valor absoluto dos milímetros tem antes que ser dividido por 1000. O mesmo raciocínio aplica-se para a determinação da quantidade total de ações negociadas na Bovespa.

Finalmente, comparando com as informações divulgadas por outras bolsas como a NYSE, Nasdaq, etc. nota-se que aquelas bolsas divulgam o movimento diário pela quantidade total de ações negociadas e quase nunca referem-se ao volume de US$ negociado. A quantidade total de ações negociada é uma variável livre enquanto o volume total de $$ é uma variável dependente.

Penso que com base nesta demonstração haverá necessidade de se alterar a metodologia de cálculo da coluna relativa à Quantidade da tabela "Resumo das Operações Realizadas". Seria conveniente que a Bovespa disponibilizasse no seu site a série histórica da quantidade total de ações negociadas, em formato Excel, para uso nos software de Análise Técnica tipo Metastock.

por Benjamin Himelgryn
e-mail: benjah@zaz.com.br

retornar


A JANELA PRINCIPAL

A janela principal do conversor Spero (fig. 2) possui um grupo de comandos denominado "Tratamento do BDI", que contém um campo de entrada de data, três botões (Processar, Cancelar e Calendário) e uma barra de progressão; do lado direito, a janela possui uma coluna com mais quatro botões (Ajuda, Sobre, Opções... e Fechar); abaixo, está a barra de status.

Tela principal do conversor Spero
Fig. 2: Janela principal do conversor Spero

A barra de status informa a função de cada botão da janela principal do conversor; basta colocar o cursor do mouse sobre um elemento da janela para que a barra de status dê uma pequena dica sobre aquele específico elemento. A barra de status também é utilizada para dar determinadas informações úteis durante a execução do processamento do BDI.

As funções dos comandos do grupo de "Tratamento do BDI" são:

  • Campo de entrada da data do pregão: você deve utilizar este campo para informar ao conversor Spero qual a data do pregão do arquivo BDI que você quer processar; esta data deve ser informada utilizando o formato DD/MM, ou Dia/Mês, sempre com dois dígitos. Exemplo: para informar a data de 2 de março, você deve digitar 02/03. É permitido informar a data do pregão no formato MM/DD apenas no caso em que o processamento do BDI for configurado para iniciar na etapa da descompressão.

    Note que toda vez que o conversor for acionado, este campo já surgirá pré-preenchido com a data do último provável pregão realizado.

  • Botão Processar: clique neste botão para dar início ao processamento do arquivo BDI relativo à data do pregão informada no campo de entrada de data. Conforme se verá mais adiante, o processamento do BDI é configurável pelo usuário, ou seja, ele pode significar apenas uma simples conversão ou pode também implicar em uma transferência do arquivo do site da Bovespa; este assunto será comentado com mais detalhes quando da descrição das funções do botão "Opções...".

    Menu com a seleção das etapas de processamento
    Fig. 3: Menu pop-up do botão Processar

    Ao se clicar o botão secundário do mouse sobre o botão Processar, surge um menu pop-up (fig. 3) que mostra as etapas de processamento e uma marca ao lado daquelas que estão atualmente selecionadas. Em versão futura, este menu deixará de ser meramente informativo e passará a ter o poder de, efetivamente, alterar a seleção das etapas de processamento.

  • Botão Calendário: ao clicar neste botão, surgirá a diálogo de seleção de data do pregão (fig. 4). Por meio deste diálogo, você tem uma alternativa à seleção da data do pregão via mouse, sem a necessidade de digitá-la diretamente no campo de entrada de data; basta selecionar e clicar no dia desejado, no diálogo de seleção de data, que a data automaticamente será preenchida no campo de entrada de data.

    Calendário para seleção da data do pregão
    Fig. 4: Diálogo de seleção de data do pregão

    Você pode selecionar um determinado mês clicando nas setas à direita ou à esquerda na parte superior do diálogo ou clicando diretamente no nome do mês e selecionando o mês desejado. A informação do ano é desprezada, para efeito de preenchimento do campo de entrada de data do pregão, embora não seja desprezada para efeito de se determinar se a data é um sábado, domingo ou feriado; para alterar facilmente o ano, clique sobre o mesmo e use as setas que surgem.

    Embora o calendário aceite a seleção múltipla de datas, o conversor Spero, nesta versão, ainda não está preparado para processar mais de um BDI por vez, exceto a conversão via Drag & Drop.

  • Botão Cancelar: clique neste botão se quiser cancelar o andamento do processamento; se você iniciou o processamento do BDI por meio do botão "Processar" e resolveu que quer desistir (especialmente durante uma transferência do arquivo BDI do site da Bovespa, que pode estar muito lenta, ou quando utilizando conversão múltipla via Drag & Drop), você deve clicar neste botão que estará ativado.

  • Barra de progressão: esta barra é informativa e mostra, graficamente, qual o percentual da transferência do arquivo BDI já realizado.

As funções dos demais elementos da janela principal são:

  • Botão Ajuda: este botão chama o Manual do Usuário off-line do conversor Spero (este manual). Só será possível o acesso ao manual off-line se o usuário tiver instalado, em seu computador, o navegador Internet Explorer versão 3.02 ou superior.

    Se você não estiver conseguindo acessar o Manual do Usuário off-line, quando clicar neste botão do conversor, significa que seu computador não está preparado para ler o formato do manual, logo, você somente terá a opção de acessá-lo online, ou seja, conectando-se à Internet.

  • Botão Sobre: clique neste botão para obter informações sobre a versão do conversor Spero (fig. 5). Na versão de demonstração, aparece a palavra "DEMO", entre parênteses, ao lado do número da versão do programa; na versão comercial, aparece, em lugar de "DEMO", a data de vencimento licenciada.

    Informações sobre a versão do conversor Spero
    Fig. 5: Diálogo Sobre o Conversor Spero

    A partir deste diálogo o usuário pode ainda ter acesso direto à página principal do site oficial do conversor e, a partir dela, ao seu Manual do Usuário online.

  • Botão Opções...: este botão dá acesso ao diálogo de configuração da conversão do BDI, entre outras funções. O diálogo de opções de configuração da conversão está descrito em detalhes logo mais adiante.

  • Botão Fechar: ao clicar neste botão, você encerra a execução do conversor Spero.

Por meio da janela principal pode-se também efetuar conversões múltiplas de arquivos BDI, utilizando a operação especial de Drag & Drop, ou seja, arrastando (drag) e soltando (drop) o botão primário do mouse.

Operação Drag & Drop: Para tanto, siga os seguintes passos:

(a) com o conversor Spero acionado, abra o Windows Explorer; com isso, você fica com duas janelas à vista, uma relativa ao conversor Spero e outra referente ao Windows Explorer;

(b) no Windows Explorer, vá ao diretório onde estão os arquivos BDI zipados e selecione todos os que deseja converter (utilize as teclas Shift e Control para fazer as seleções múltiplas);

(c) clique com o botão primário do mouse sobre a seleção múltipla, no Windows Explorer e, mantendo o botão pressionado, arraste o cursor do mouse para a janela do conversor Spero (se ela não estiver visível, arraste para o ícone do conversor que se encontra na barra de tarefas do Windows, mantenha esta posição por um instante e espere a janela do conversor aparecer na tela; na seqüência, mantendo o botão do mouse sempre pressionado, escorregue o cursor para a janela do conversor que acabou de aparecer);

(d) solte o botão do mouse sobre a janela do conversor que ele automaticamente começará a realizar as conversões.

As conversões via Drag & Drop respeitam, obviamente, as configurações do diálogo de configuração da conversão, entretanto ela é indiferente à seleção das etapas de processamento da página de Etapas do diálogo de configuração (explicado mais adiante). A conversão via Drag & Drop irá sempre apenas descomprimir e converter os arquivos BDI soltados sobre a janela principal, gerando os respectivos novos arquivos intermediários; ela não irá alterar o diretório de armazenamento dos BDI, mesmo que esta etapa esteja selecionada no diálogo de configuração. Os arquivos intermediários gerados serão sempre armazenados no mesmo diretório onde se encontram os arquivos BDI que foram soltos sobre a janela principal.

O objetivo principal do recurso de conversão múltipla é permitir aos usuários um rápido reprocessamento dos arquivos BDI, por exemplo, para indexar as cotações passadas, utilizando o recurso de "Interromper para informar", descrito posteriormente. Assim, uma vez reprocessados os BDI e gerados os novos arquivos intermediários, basta levá-los ao DownLoader, que também aceita conversão múltipla, para ter suas cotações atualizadas, segundo a configuração que achar mais adequada. O único inconveniente, neste processo, é o tempo levado pelo DownLoader para processar os arquivos intermediários, especialmente quando em grande quantidade.


O DIÁLOGO DE CONFIGURAÇÃO DA CONVERSÃO

O diálogo de configuração da conversão, mostrado quando se clica no botão "Opções..." da janela principal, é composto de quatro páginas: Formatação, Mercados, Etapas e Miscelânea. Abaixo das páginas há dois botões, OK e Cancelar que servem, respectivamente, para confirmar (aplicar e gravar) as alterações efetuadas pelo usuário e para cancelar as alterações selecionadas, antes da sua confirmação.

Formatação

A página de Formatação (fig. 6) tem por função principal permitir ao usuário do conversor selecionar entre algumas opções de formatação do arquivo resultante da conversão (o arquivo intermediário).

Página de configuração da formatação
Fig. 6: Página de Formatação do diálogo de configuração da conversão

Ela é composta de três grupos de elementos: Volume, Ticker e Indexação. Suas funções estão descritas a seguir.

  • Volume: neste grupo, você pode selecionar qual informação de volume do BDI da Bovespa você quer que seja transferida para as suas cotações do MetaStock (via arquivo intermediário). Você pode optar entre o volume negociado em reais ou o volume em quantidade de títulos.

    As informações de volume dos índices, sejam em reais ou em quantidade de títulos, referem-se, especificamente, à participação dos três índices calculados pela Bovespa, a saber, o Ibovespa (Índice Bovespa), IBX (Índice Brasil) e IEE (Índice de Energia Elétrica). Nenhum desses volumes terá correspondência com os dados de "volume negociado" da Bovespa, divulgados pela mídia, em geral, pois o volume negociado pela Bovespa engloba o total geral do pregão, seja em reais ou em títulos, e não tem relação com os índices, embora, obviamente, os volumes dos índices façam parte do volume total geral.

    Note, ainda, que as informações de volume originais do BDI podem ser afetadas pelas opções de Indexação (vide mais adiante) e pelo "ajuste da quantidade total", constante nas opções de Compatibilidade (página de Miscelânea, discutida posteriormente).

  • Ticker: permite a escolha entre trabalhar com o formato de ticker proprietário do conversor Spero ou com o código oficial da Bovespa, para os papéis negociados. O formato proprietário de ticker do conversor Spero é compatível com as versões anteriores deste programa, à exceção do mercado a termo (vide nota abaixo), e está descrito no Guia de Conversão dos Arquivos ASCII, sob o tópico "Conteúdo dos Arquivos ASCII".

    Os tickers oficiais da Bovespa correspondem aos códigos de até oito caracteres utilizados por ela para identificar cada papel negociado no pregão. A regra de formação desses códigos está descrita em documento disponível para transferência no próprio site da Bovespa, denominado layout do BDI.

    Nota Importante: as regras de formação dos tickers para o mercado a termo sofreram alterações em ambas as opções (formato proprietário e oficial), em função da necessidade de diferenciar os vários prazos a que um mesmo código de papel pode estar sujeito. Veja, na página seguinte, detalhes sobre essas novas regras do mercado a termo.
  • Indexação: permite a indexação dos valores do BDI. Ao selecionar a opção "Indexar:", o diálogo abre um campo de edição onde você deve informar qual o valor da indexação desejada. Durante o processamento do BDI, o conversor Spero irá dividir (a) todas as cotações dos papéis (abertura, máxima, mínima e de fechamento) - exclusive a dos índices da Bovespa - e (b) os volumes (se negociados em reais) pelo valor de indexação informado. Normalmente você vai querer utilizar este campo para indexar os valores do BDI ao dólar americano. Se esta opção não for selecionada ou se nenhum valor de indexação for informado, as cotações e volumes transferidos para o arquivo intermediário serão os originais do BDI da Bovespa, sem qualquer alteração de indexação.

    É possível indexar também as cotações dos índices da Bovespa (Ibovespa, IBX e IEE), dadas em pontos (abertura, máxima, mínima e de fechamento), pelo mesmo valor de indexação utilizado para os valores em reais. Para isso, selecione a opção "Cotações dos índices".

    A indexação pode, ainda, atingir os volumes, se em quantidade de títulos. Neste caso, selecione a opção "Volumes em títulos". Esta opção só se mostra habilitada se o volume estiver selecionado em "Quantidade de Títulos".

    O quadro abaixo resume, de forma esquemática, as três opções de indexação, sendo que "Padrão" significa a seleção simples da opção "Indexar:":

    INDEXAÇÃO

    Cotações

    Volumes

    Em R$

    Em Títulos

    Índices

    "Cotações dos índices"
    (em pontos)

    Padrão

    "Volumes
    em
    títulos"

    Papéis

    Padrão
    (em R$)

    Conforme explicado anteriormente, ao fazer a conversão, o conversor utiliza o valor de indexação informado no campo ao lado da opção "Indexar:". Caso este índice sofra variações constantes, é possível solicitar ao conversor que, no ato do processamento do BDI, ele suspenda, temporariamente a conversão, e solicite, ao usuário, o valor de indexação desejado para o dia de pregão que está sendo processado naquele momento, ou seja, é possível o fornecimento do valor de indexação on the fly (fig. 6a). A vantagem da indexação on the fly é que não é necessário entrar no diálogo de Configuração da Conversão, sempre que se quiser alterar valor.

    Diálogo de entrada do valor de indexação on the fly
    Fig. 6a: Diálogo de entrada do valor de indexação on the fly

    Durante a operação de processamento via Drag & Drop, a indexação on the fly é quase que uma necessidade, se houver a opção pela indexação e se os índices forem diferentes, de um pregão ao outro. Para solicitar a indexação on the fly ao conversor, selecione a opção "Interromper para informar". O último valor de indexação informado on the fly é automaticamente salvo no campo do valor de indexação do diálogo, substituindo eventual valor existente.

    Divisão por Mil

    Dentro do quadro de indexação, existe ainda a opção da divisão dos volumes por mil. Se você quiser que os volumes dos índices da Bovespa, independentemente de estarem selecionados como negociados em reais ou em quantidades de títulos, sejam divididos por mil, você deve selecionar a opção "Apresentar índices por mil". Com isso, os valores ficam menores e facilita a leitura dos volumes no programa MetaStock.

    A divisão por mil atinge os seguintes volumes:
    (a) os volumes dos três índices da Bovespa (Ibovespa, IBX e IEE), independentemente de estarem selecionados como negociados em reais ou em quantidades de títulos, e
    (b) os volumes dos papéis que são negociados em lotes de mil, desde que selecionados em quantidade de títulos.

    Por conseqüência, a divisão por mil não atinge os volumes dos papéis:
    (a) quando selecionados em reais, ou
    (b) quando em quantidade de títulos, porém negociados por ação.


Etapas do Processamento

A próxima página das opções de configuração é a página de Etapas (fig. 8). Ela é composta de um único grupo de elementos, denominado "Etapas do Processamento" do BDI e tem por objetivo permitir ao usuário selecionar por quais fases de processamento ele deseja que o conversor passe, ao tratar o BDI selecionado.

Seleção das etapas de processamento do BDI
Fig. 8: Página de Etapas do diálogo de configuração da conversão

Há seis fases, ou etapas, possíveis de serem processadas pelo conversor Spero. Elas estão descritas, em detalhes, mais adiante.

Antes, porém, para dar uma visão geral de como o conversor trabalha, de suas etapas, abaixo segue um esquema básico descrevendo, sucintamente, as funções de cada uma das principais etapas, a saber, transferência, conversão, armazenamento e acionamento.

Fluxo esquemático do processamento do conversor
Fig. 9: Fluxo Esquemático das Principais Etapas do Conversor

Portanto, observando o esquema acima, pode-se resumir o processamento completo do conversor, da seguinte forma, para uma determinada data selecionada:

  1. Verifica a existência do BDI, no servidor da Bovespa e, em estando disponível, o transfere para o diretório de trabalho; é necessária uma conexão ativa com a Internet;
  2. Descomprime o BDI (pois ele chega da Bovespa em formato comprimido ZIP) e o converte, segundo as configurações determinadas pelo usuário; a conversão não altera o arquivo original BDI mas sim gera, ou cria, um novo arquivo, com extensão (ou, do tipo) PRN, que fica no diretório de trabalho;
  3. Altera o nome do arquivo original BDI e o move, do diretório de trabalho, para um diretório específico de armazenamento de BDIs;
  4. Executa o programa The DownLoader e faz com que o DownLoader, a partir do arquivo recém-criado .PRN, atualize o diretório de cotações do usuário, com as informações do dia a que se refere o BDI recém-transferido.

Note que há duas conversões envolvidas em todo o processo de atualização das cotações. A primeira é realizada pelo conversor Spero, que lê as informações contidas dentro do arquivo BDI da Bovespa e as transforma em um novo arquivo, de nome semelhante ao do BDI original, porém com extensão - terminação - do tipo PRN. A segunda conversão não é feita pelo conversor mas sim pelo programa The DownLoader, que lê as informações contidas dentro do arquivo PRN, criado pelo conversor, e, a partir delas, atualiza as cotações em formato MetaStock no diretório de cotações, propriamente, ou seja, as cotações que o MetaStock consegue ler e a partir das quais o usuário faz suas análises técnicas e gráficas. Metaforicamente falando, poder-se-ia dizer que o conversor Spero faz uma ponte entre o arquivo BDI da Bovespa e o programa The DownLoader, já que este último não consegue entender o layout do BDI.


DESCRIÇÃO DETALHADA

Após a breve descrição anterior, a seguir detalham-se todas as etapas envolvidas no processamento do conversor Spero, possíveis de configurar por meio do diálogo em foco:

  • Verificar disponibilidade: esta etapa simplesmente verifica se o arquivo BDI, relativo à data do pregão, informada no respectivo campo de entrada (da janela principal), existe no servidor da Bovespa e se está disponível para transferência. É necessário haver uma conexão ativa com a Internet.

  • Transferir da Internet: esta opção, se selecionada, efetua a transferência do BDI, relativo à data do pregão informada no campo de entrada, do servidor da Bovespa para o diretório de trabalho do conversor Spero. Obviamente é necessário que haja uma conexão ativa com a Internet para que seja possível a transferência e que o arquivo esteja disponível no servidor da Bovespa. Caso não haja uma conexão ativa, o programa lhe dará a oportunidade de se conectar com o seu provedor, se o seu acesso à Internet for do tipo discado (se você estiver conectado à Internet via rede, certifique-se de que a conexão esteja ativa). Caso o arquivo desejado não esteja disponível no servidor da Bovespa, uma mensagem de aviso será passada ao usuário.

    A seleção desta etapa implica, automaticamente, na seleção - interna ao conversor - da etapa de verificação da disponibilidade do arquivo. A recíproca, entretanto, não é verdadeira.

    O progresso da transferência é mostrado na barra de progressão do conversor. A transferência do arquivo via Internet pode ser abortada a qualquer momento pressionando-se o botão Cancelar, na janela principal do conversor Spero.

    Uma curiosidade interessante e que o usuário do conversor logo notará é que, embora no site oficial da Bovespa constem apenas alguns poucos arquivos BDI de pregões anteriores, por meio do conversor Spero será possível transferir BDI bem mais antigos, isto porque, embora a página de pregões anteriores da Bovespa não mostre a existência dos arquivos, eles ainda estão armazenados no servidor e podem ser transferidos. A etapa de transferência do conversor Spero (ou a de verificação de disponibilidade) informam ao usuário se o arquivo relativo ao pregão selecionado está ou não disponível para download, independentemente da informação prestada na página de pregões anteriores da Bovespa, pois ela busca o arquivo diretamente no servidor da Bovespa.

  • Descomprimir: esta opção, quando selecionada, descomprime automaticamente o arquivo BDI transferido do servidor da Bovespa, ou contido no diretório de trabalho do conversor Spero, relativo à data do pregão informada no campo de entrada. O arquivo resultante da descompressão, denominado pela Bovespa de "bdin", é armazenado no diretório de trabalho do conversor.

    Esta etapa aceita que o campo de entrada de data do pregão seja preenchido tanto no formato DD/MM quanto no formato MM/DD. O formato MM/DD somente pode ser informado manualmente; o uso do calendário sempre resultará em data de pregão no formato DD/MM. O motivo de a descompressão aceitar o formato MM/DD deve-se ao fato de que o usuário pode querer reprocessar arquivos BDI que foram renomeados (vide etapa Renomear e Armazenar, mais adiante).

  • Converter para formato ASCII: esta opção converte o arquivo descomprimido, de nome "bdin", no arquivo intermediário, ou seja, no arquivo em formato ASCII, para uso posterior com o programa The DownLoader. Durante a conversão, são utilizadas as opções selecionadas nas páginas de configuração da conversão. O arquivo resultante da conversão, de nome Bdinmmdd.PRN, onde "mm" corresponde ao mês e "dd" ao dia do pregão, é armazenado no diretório de trabalho do conversor.

    Esta etapa, por si só, não leva em consideração a data do pregão informada no campo de seleção. Ela busca por um arquivo de nome "bdin", no diretório de trabalho do conversor, e, em o encontrando, tenta convertê-lo, segundo as configurações estabelecidas, independentemente de a que data ele possa se referir. Após a conversão o arquivo de nome "bdin" será apagado do diretório de trabalho.

    Uma vez que não parece ser comum optar pela conversão sem optar também pela descompressão, pois elas são interdependentes, ao se selecionar esta etapa o conversor, automaticamente, sugere a seleção da etapa de descompressão; no entanto, caso o usuário queira, poderá desmarcar a descompressão.

  • Renomear a Armazenar: esta opção, se selecionada, informa ao conversor que ele deve renomear o arquivo BDI que veio do servidor da Bovespa de Bdiddmm.ZIP (nome original da Bovespa, onde "dd" refere-se ao dia e "mm", ao mês do pregão) para Bdimmdd.ZIP, ou seja, inverter "dd" com "mm". Esta inversão do nome tem por finalidade facilitar o armazenamento dos BDI transferidos da Bovespa, segundo a ordem cronológica dos pregões.

    Após renomear o arquivo, o conversor irá movê-lo do diretório de trabalho do conversor para um subdiretório deste, de nome "Armazem". Se o subdiretório Armazem não existir, ele será criado.

    A opção renomeia e armazena o arquivo BDI da Bovespa relativo ao pregão informado no campo de seleção da data do pregão. Caso o arquivo da Bovespa já esteja no formato Bdimmdd.zip, a ação de renomear é desprezada.

  • Acionar o DownLoader: esta última etapa tem por finalidade acionar, automaticamente, o programa The DownLoader, preenchendo, também automaticamente, o diálogo de conversão do DownLoader (denominado de Convert Securities) com os dados do arquivo ASCII referente ao pregão informado no respectivo campo de seleção.

    Ao selecionar, pela primeira vez, a opção "Acionar o DownLoader", o conversor Spero tentará detectar, automaticamente, o local de instalação do programa The DownLoader e o provável local onde suas ações no formato MetaStock estão armazenadas e, se conseguir, preencherá, automaticamente, os campos destinados a guardar estas informações. Caso o conversor não consiga fazer essas detecções (uma ou ambas) e o programa The DownLoader esteja, de fato, instalado em seu computador ou o diretório de cotações sugerido esteja errado, você deve informar, manualmente, o caminho completo do programa DownLoader e o caminho completo do seu diretório de cotações nos campos apropriados que são habilitados quando esta etapa for selecionada; alternativamente, você pode procurar pelo arquivo que representa o programa The DownLoader utilizando o botão reticências "...", ao lado do respectivo campo, que aparecerá, quando da seleção da etapa; da mesma forma, você pode procurar o diretório de cotações usando, também, o botão lateral ao seu respectivo campo.

    Nota: Antes de utilizar o programa The DownLoader pela primeira vez, seja manual ou automaticamente (via acionamento pelo conversor Spero), suas opções de conversão precisam ser ajustadas manualmente. Para aprender como configurar adequadamente essas opções, aconselha-se a leitura do tópico Configurando o Programa The DownLoader, do Guia de Conversão dos Arquivos ASCII.

    Quando o conversor Spero aciona remotamente o programa The DownLoader, ele chama o diálogo Convert Securities ("conversão dos papéis") e preenche, automaticamente, o campo Folder ("pasta" ou "diretório"), tanto do grupo Source ("origem") quanto do grupo Destination ("destino"), e o campo File Name ("nome do arquivo") do grupo Source, da seguinte forma:

    • No grupo Source:
      - campo Folder: o caminho completo do diretório de trabalho do conversor Spero, que é onde se encontram os arquivos intermediários (ASCII), extensão .PRN;
      - campo File Name: o nome do "Bdimmdd.prn" que acabou de ser processado pelo conversor ou relativo à data do pregão informado no campo de entrada.
    • No grupo Destination:
      - campo Folder: o caminho completo do diretório de destino, ou diretório de cotações, onde estão armazenadas as cotações no formato MetaStock; esta informação deve ser fornecida pelo usuário do conversor, no campo "Pasta de cotações:" (vide a seguir);
      - campo File Name: não é utilizado (permanece desabilitado).

    Além dos efeitos acima, o acionamento remoto também tenta enviar, ao diálogo Convert Securities, informações para a correta seleção dos campos File Type ("tipo de arquivo"), tanto do grupo Source quanto do Destination, completando, assim, o preenchimento total do diálogo. Entretanto, o envio destas informações é feito por meio do registro do Windows, um local onde todas as informações de configuração de todos os programas que estão instalados no computador ficam armazenadas, de forma permanente. Não há como o usuário saber, explicitamente, se tal envio foi bem sucedido, entretanto, ele pode fazer um teste simples, configurando o diálogo Convert Securities de forma errada e acionando o conversor, para ver se a configuração foi automaticamente corrigida. Se, ao selecionar a etapa de acionamento remoto pela primeira vez, o caminho do DownLoader for preenchido automatica e corretamente no campo apropriado (vide acima), muito provavelmente as informações do campo File Type serão, também, repassadas corretamente, via registro do Windows. Note, por fim, que, se o repasse da informação do campo File Type não for bem sucedida, o conversor simplesmente a ignorará, não gerando erro ao usuário.

    Nota Importante: Há uma limitação nos dados que o conversor Spero pode enviar ao DownLoader. O usuário não deve instalar o DownLoader ou ter a pasta de cotações em diretórios com nomes que utilizam caracteres acentuados. Alguns caracteres acentuados são suportados pela etapa de acionamento remoto porém, outros não o são. Assim, não utilize acento nos nomes de ambos estes diretórios, por precaução.

    Finalização do Acionamento Remoto

    Outro ponto importante que merece ser esclarecido diz respeito à independência entre a atuação do conversor Spero e a atuação do DownLoader. Após passar as devidas instruções para o DownLoader, o conversor Spero já fez a sua parte e, se tudo correu bem nas etapas anteriores, ele dará, imediatamente, a mensagem de processamento finalizado com sucesso. O tempo de duração da conversão do DownLoader pode variar bastante, de um computador para outro, em função da capacidade de processamento e da rapidez do sistema de armazenamento, entre outros fatores. Uma vez que o DownLoader for acionado pelo conversor, o trabalho dele é totalmente independente da finalização do conversor Spero; o conversor (nesta versão) ainda não ganhou a capacidade de saber se o DownLoader gerou algum erro durante a sua conversão para o formato MetaStock. O usuário deve ficar portanto atento ao relatório final de conversão gerado pelo DownLoader quanto à existência de erros. O sucesso da operação de conversão do Downloader estará garantido se, ao aparecer o relatório de conversão, Conversion Report, este trouxer, no quadro de Status, a mensagem de Conversion : Data Converted And Stored. Veja, ao final do tópico Convertendo os Arquivos ASCII, do Guia de Conversão dos Arquivos ASCII, maiores detalhes sobre a correta finalização da operação do DownLoader.

    O conversor Spero está preparado para acionar o DownLoader, qualquer que seja o estado em que o programa se encontrar: minimizado, normal ou não acionado. Entretanto, por questões internas ao conversor, aconselha-se que o conversor Spero seja acionado com o DownLoader fechado, ou seja, aconselha-se que se deixe ao conversor a tarefa de acionar o DownLoader. Este procedimento não é necessário embora seja recomendado. De qualquer forma, tendo ou não acionado efetivamente o DownLoader, o conversor Spero não irá fechá-lo automaticamente.

A princípio, a seleção das etapas pelas quais o processamento deve passar foi disponibilizada ao usuário do conversor supondo que o mesmo irá seguir uma seqüência lógica de processamento. Não faria muito sentido o usuário selecionar a etapa de transferência do arquivo seguida da etapa de acionamento do DownLoader, sem selecionar a descompressão e a conversão. Do ponto de vista do conversor, entretanto, ele sempre irá seguir as determinações do usuário, da melhor forma possível: se a seqüência de etapas selecionada for racional, o conversor tratará a mesma como uma tarefa única a ser realizada, enviando uma mensagem única ao usuário ao final da última etapa, desde que não ocorra nenhum problema durante a execução das etapas intermediárias; se a seqüência de etapas selecionada pelo usuário não for lógica, o conversor tratará cada etapa como uma tarefa em separado, enviando uma mensagem após a finalização de cada uma dessas etapas. De qualquer forma, qualquer erro que ocorra em qualquer uma das etapas selecionadas sempre acarretará a paralisação de todo o processo.


Futuros Melhoramentos Idealizados

A versão 0.99e do conversor Spero já é praticamente considerada a primeira versão final, devido à sua boa estabilidade e à qualidade e quantidade de recursos disponíveis.

Entretanto, como tudo que nos rodeia, sempre há espaço para melhorias. Alguns outros recursos estão planejados para ser implementados no conversor Spero, em um futuro não muito distante. Eles estão mencionados na lista a seguir, a qual não é, obviamente, conclusiva, mas está em constante mutação, em função de novas idéias trazidas pelos usuários do Spero.

  • adicionar a possibilidade de selecionar e processar (transferência da Internet e acionamento remoto do DownLoader) vários BDI em um só processo, com opção de transferência, via Internet, seqüencial ou múltipla;
  • adicionar ao menu sensitivo ao contexto (menu pop-up) do botão "Processar" a capacidade de alterar a seleção das etapas de processamento;
  • adicionar a seleção individual de papéis, além da já implementada seleção por mercado;
  • adicionar ao conversor a capacidade de monitorar o processamento do DownLoader, quando acionado remotamente, podendo assim, a critério do usuário, apagar ou não os arquivos intermediários do diretório de trabalho;
  • adicionar a possibilidade de o usuário poder escolher o diretório de trabalho, independentemente da localização da instalação do conversor;
  • permitir a discagem à Internet de dentro do próprio conversor;
  • permitir a opção de renomear os arquivos BDI para BDIaaaammdd.zip.

Não existe, porém, garantia de que as idéias expostas acima serão efetivamente implementadas. Os usuários devem se sentir à vontade para enviar sugestões de novos recursos, melhoramentos dos existentes, ou críticas quanto ao funcionamento do conversor e, especialmente, para reportarem erros de processamento - bugs - eventualmente ocorridos durante a utilização do conversor Spero, ou erros de definição dos recursos.


Considerações Finais e Histórico das Versões

O conversor Spero foi feito para ser executado em qualquer ambiente do Windows (95/98/ME/ NT/2000).

Como referência, a seguir, um breve resumo do histórico das versões do conversor Spero, desde o lançamento da precursora macro UBolsa.

  • Conversor Spero - versão 0.99e: funcionalmente idêntica à versão anterior ("d"), porém, a partir desta versão, o conversor passa a ser compatível com o sistema operacional profissional do Windows (Windows NT/2000). O conversor passou a ser um programa comercial; portanto, a versão "e" corresponde à versão "d" comercial. Disponibilizada em 1º/08/00.
  • Conversor Spero - versão 0.99d: novas funcionalidades desta versão do programa Spero; implementados a indexação opcional das cotações dos índices e dos volumes em títulos, indexação on the fly, pasta de cotações configurada na etapa de acionamento remoto, possibilidade de retroceder a data do pregão em 28 anos, campo O/I opcional com número de negócios ou de distribuição, ajuste da quantidade total de títulos do Ibovespa (fator BH), título reduzido opcional e alteração necessária no ticker dos papéis do mercado a termo. Disponibilizada em 27/03/00.
  • Conversor Spero - versão 0.99c: terceira versão do programa Spero; implementados o menu pop-up do botão Processar (apenas informativo), a barra de progressão, as opções da miscelânea, a configuração do processamento, a conversão múltipla via Drag & Drop e a instalação automática; a indexação tornou-se mais abrangente; disponibilizado aos usuários em 1º/03/99. Disponibilizada uma atualização do prazo de vencimento em 27/06/99 e uma segunda atualização em 24/12/99.
  • Conversor Spero - versão 0.99b: segunda versão do programa UBolsa, renomeado para conversor Spero. Recursos operativos: seleção do tipo de ticker e de volume, indexação do volume, volume por mil, seleção dos mercados a converter, processamento limitado à descompressão e à conversão automáticas, calendário para seleção de data, barra de status com dicas e ajuda via Internet; disponibilizado aos usuários em 30/01/99.
  • Programa UBolsa - versão 0.99a: primeira versão do programa que tem por objetivo substituir a macro UBolsa, em formato de arquivo executável (não necessita do Excel para funcionar). Sua única função é converter o arquivo BDI descomprimido no arquivo intermediário, sem quaisquer recursos extras; disponibilizado aos usuários em 15/12/98.
  • Macro UBolsa - versão 2.0a: disponibilizada em 04/05/98, versão ainda em forma de suplemento, agora do Excel/97, que trata os BDI posteriores a 13/03/98.
  • Macro UBolsa - versão 1.0: suplemento do Excel/95 que tratava os BDI anteriores a 16/03/98. Nunca foi disponibilizada via Internet.

Se você quiser imprimir este manual, caso a impressão direta não fique boa ou não seja possível, aconselho selecionar todo o texto da página (clique com o botão secundário do mouse sobre este texto para surgir o menu pop-up e, depois, clique em "Selecionar todos"), copiá-lo e colar a seleção no Bloco de Notas ou em outro editor de texto; nesse último caso, a dica é que você cole o texto como "não formatado"; para isso, no Word, por exemplo, use o comando "Colar Especial".


Instalação do Conversor SPERO

Para instalar o conversor Spero, o usuário precisa executar o arquivo de distribuição, ou arquivo de instalação, ISpero.exe, que acionará o programa de instalação automático e proporcionará uma instalação transparente ao usuário, que precisará apenas seguir as instruções mostradas na tela, durante o processo. Além da segurança, praticidade, facilidade e rapidez no processo de instalação, o instalador dá, ao usuário, a opção de selecionar a pasta onde o programa será instalado, aqui denominada de diretório de trabalho (anote bem o conceito de diretório de trabalho pois ele é importante para entender o correto funcionamento do conversor), entre outras opções.

Como padrão, o programa de instalação irá criar, automaticamente, um grupo de ícones no menu Iniciar/Programas, e ícones específicos para acionamento do conversor na Área de Trabalho e na barra de ferramentas "Iniciar Rapidamente". A partir do grupo de menu Iniciar/Programas, o usuário terá acesso ao Desinstalador do conversor Spero. Acionando o desinstalador,o usuário poderá, a qualquer momento, desinstalar completamente o programa, sem deixar vestígios ou arquivos não mais utilizados em seu disco rígido, especialmente limpando a chave do registro do Windows criada pelo conversor, quando da sua instalação, e utilizada para armazenar dados de configuração. O desinstalador também pode ser acessado por meio do ícone "Adicionar ou remover programas" do Painel de Controle.

Nota aos usuários da versão de demonstração: a desinstalação do conversor Spero utilizando o desinstalador fornecido elimina todos os vestígios do conversor que estejam em seu computador, exceto arquivos que foram armazenados por você próprio ou criados durante as conversões. O lado negativo é que, ao desinstalar o conversor, você perde o registro das configurações do conversor até então utilizadas. Com isso, quando, eventualmente, você for instalar novamente o conversor, deverá acionar o botão "Opções" e reconfigurar as opções de tratamento do BDI de acordo com o formato utilizado em sua pasta de cotações. Por isso, caso você esteja apenas atualizando o conversor de uma versão anterior ou da versão de demonstração para a versão comercial, não é aconselhável desinstalar, previamente, a versão anterior; neste caso, simplesmente instale a versão comercial no mesmo diretório onde está instalada a versão anterior; com isso, a versão nova se sobrepõe à atual sem perda das configurações existentes no registro: a versão nova lê, no registro, as configurações, e, automaticamente, se auto-ajusta a elas (leia uma importante ressalva a este auto-ajuste, ao final desta página). Ainda assim, por precaução, aconselha-se fazer uma cópia da sua base de cotações, até ter certeza de que a nova versão está atualizando sua base da forma apropriada.

Durante a instalação, o usuário terá a opção de não instalar nenhum ícone em seu computador. Se assim optar, o único modo de acionamento do conversor Spero será utilizando o Windows Explorer, indo ao diretório onde o conversor foi instalado, e acionando-o diretamente de lá. O usuário poderá, obviamente, criar ícones manualmente.

Para instalar o conversor Spero em seu computador, siga, com atenção, os poucos passos descritos a seguir.

1 Transfira o arquivo de distribuição ISPERO.EXE para o seu computador (vide tópico ao final deste manual).

2 A partir de qualquer diretório, execute o arquivo ISPERO.EXE e siga as instruções que o assistente de instalação apresentará na tela (fig. 1).

Tela inicial do programa de instalação
Fig. 1: Tela inicial do Programa de Instalação (arte não original)

3 Pronto! O conversor já está corretamente instalado. Para executá-lo, se você seguiu os passos do instalador, sem alterar as seleções propostas, basta ir ao menu Iniciar/Programas, localizar o grupo "Conversor Spero" e clicar no ícone correspondente. Você tem ainda as opções de ícones na Área de Trabalho e na barra de ferramentas "Iniciar Rapidamente".

Se você não desejar ter atalhos do conversor na área de trabalho ou na barra de ferramentas "Iniciar Rapidamente", clique nestes ícones, com o botão secundário do mouse, e, simplesmente, os exclua.

Nota Final ao Atuais Usuários: os atuais usuários do conversor Spero que estavam utilizando a opção de acionamento remoto do programa The DownLoader devem, necessariamente, selecionar novamente esta opção, na página "Etapas" do diálogo de "Configuração da Conversão", acessado via botão "Opções...", pois, mesmo que esta opção estivesse selecionada na versão anterior, por questões de segurança, ela é limpada (zerada) pelo instalador. Maiores detalhes de como selecionar a opção podem ser encontrados na página de Seleção das Etapas.


Apresentamos o Conversor SPERO, um programa de conversão do BDI da Bovespa (Boletim Diário de Informações da Bolsa de Valores de São Paulo), de interesse das pessoas que fazem uso do programa comercial de análise de ações MetaStock, da Equis Internetional, versão 6.52 ou superior, ou de qualquer outro programa que trabalhe com arquivos no formato MetaStock.

O programa Conversor Spero tem, por finalidade básica, permitir que os usuários de cotações de papéis, em formato MetaStock, negociados pela Bovespa, possam atualizar as cotações diariamente, com base no arquivo distribuído pela Bovespa em seu site oficial. Para tanto, o conversor Spero gera um arquivo, em formato "ASCII Text" (texto puro), que posteriormente deve ser levado ao programa The DownLoader (que acompanha o programa MetaStock) para efetuar a conversão final até o formato MetaStock. Ou seja, entre o arquivo da Bovespa, que é incompreensível para o programa The DownLoader, e os arquivos contendo as cotações dos papéis em formato MetaStock, faz-se uso de um arquivo intermediário, em formato específico, que o DownLoader pode processar. É este arquivo intermediário que o conversor Spero gera, ao final do seu processamento.

Este manual pressupõe que o usuário tenha alguma familiaridade com o programa The DownLoader e o processo de conversão feito pelo mesmo. Para aqueles que nunca o utilizaram, aconselha-se, antes de ler este manual e de começar a utilizar o conversor Spero, a leitura prévia e atenciosa do Guia de Conversão dos arquivos ASCII para conhecer melhor o conteúdo dos arquivos intermediários "ASCII Text", gerados pelo conversor Spero, e obter informações sobre como convertê-los para o formato MetaStock, utilizando o programa The DownLoader.

Note que MetaStock pode significar tanto o nome do programa de análise de ações, desenvolvido e comercializado pela Equis International, como o nome do formato dos arquivos que o programa MetaStock utiliza, ou seja, o programa MetaStock utiliza arquivos no formato MetaStock. Também é bom ter em mente que, neste manual, as expressões "arquivos em texto puro", "arquivos ASCII", "arquivos intermediários" e "arquivos PRN" significam, todas, a mesma coisa, e são usadas indiscriminadamente, ao longo do texto, significando, sempre, o arquivo gerado pelo conversor Spero.


Mercados

A próxima página de configuração da conversão é a relativa aos mercados abrangidos pela conversão e denomina-se Mercados (fig. 7). Ela é composta de um único grupo de elementos - Mercados a Converter - que correspondem aos vários mercados de papéis que podem ser selecionados para constarem, ou não, dos arquivos intermediários, ou seja, para ser, ou não, enxergados pela conversão.

Seleçao dos mercados a converter na conversão
Fig. 7: Página de Mercados do diálogo de configuração da conversão

Por meio desta página, você pode optar entre os papéis do lote padrão, concordatárias, direitos e recibos, bônus privados, fundos e certificados, mercado a termo, opções de compra e de venda, mercado fracionário e demais (todos os não listados anteriormente).

Caso você esteja trabalhando com o formato de ticker proprietário do conversor Spero, o mnemônico do papel (primeira letra do ticker) corresponderá à tecla de atalho de seleção do respectivo papel desta página de diálogo. Exemplo: para o mercado de concordatárias, o mnemônico do papel é a letra "C", que corresponde à tecla de atalho para seleção, via teclado, da opção. Note que as teclas de atalho das opções de mercados a converter correspondem às letras sublinhadas das descrições dos papéis. Assim, no caso do mercado de concordatárias, a letra "C" que corresponde tanto à tecla de atalho quanto ao mnemônico do papel, está sublinhada na página de Mercados do diálogo de configuração da conversão.

Para o mercado a termo, no entanto, há uma exceção às regras de formação dos tickers, tanto no caso do formato proprietário do Spero quanto no caso do formato oficial da Bovespa, a saber:
(a) Para o formato proprietário, após a letra do mnemônico, normalmente seguiria o símbolo de sublinhado, "_"; entretanto, para o mercado a termo, o sublinhado é substituído por um número que lembra o prazo do papel: se igual a 30, utiliza-se o número 3; se igual a 60, o número 6; se 90, o número 9; se 120, o número 2;
(b) Para o formato oficial da Bovespa, acrescentam-se, ao final do código oficial, mais dois ou três caracteres numéricos que correspondem exatamente ao prazo do papel.


Miscelânea

A última página disponível, na configuração da conversão, é a de Miscelânea (fig. 9) cujo objetivo é dar aos usuários algumas opções de compatibilização do arquivo intermediário ASCII e de operação do conversor.

Diálogo com outras opções de formatação e operação
Fig. 9: Diálogo com outras opções de formatação e operação

Ela é composta de dois grupos de elementos: Compatibilidade e Preferências. Suas funções estão descritas a seguir.

  • Compatibilidade: neste grupo, você tem as seguintes opções de compatibilização do arquivo intermediário:

    (a) Recuar data em 28 anos: se selecionada, esta opção retrocede a data do pregão atual (que está sendo processado) em 28 anos. Esta opção tem por finalidade permitir que os programas MetaStock anteriores à versão 6.52 possam continuar sendo utilizados. Estes MetaStock antigos não são compatíveis com o ano 2000 e seguintes, pois eles entendem o ano 2000 como sendo o ano de 1900, que teve um calendário diferente do ano 2000. Assim, retrocedendo a data em 28 anos, o usuário deverá trabalhar, por exemplo, no ano 2000, como se estivesse em 1972. Uma vez que o calendário de 1972 é idêntico ao do ano 2000, é possível, com esse pequeno porém esperto artifício, manter, por mais alguns anos, a vida útil dos velhos MetaStock.

    (b) Ajustar quantidade total (Pré-divisão dos lotes por mil): um atento usuário do Spero detectou um provável erro no cálculo da quantidade total de ações negociadas, por parte da Bovespa. Com base em sua demonstração, parece claro que, de fato, a definição de quantidade total em número de títulos da Bovespa merece reflexão.

    Se você concordar com o ponto de vista do ajuste proposto, selecione esta opção. O volume total de ações negociadas, em quantidade de títulos, para o Ibovespa, e apenas para este índice, será corrigido, de acordo com o proposto no documento acima. Os índices IBX e IEE não são afetados por este ajuste porque não há elementos suficientes, no BDI não formatado, que permitam saber qual a composição desses índices. Esta opção somente é ativada se for selecionado volume em quantidade de títulos, na página de Formatação.

    (c) Usar campo Open Interest: os arquivos ASCII têm um campo opcional, chamado Open Interest e abreviado por O/I, que, segundo o manual do MetaStock, tem por finalidade "informar o número de contratos abertos para um determinado papel" ("The Open Interest indicator plots the number of open contracts of a given commodity").

    O manual explica ainda que a informação do "O/I somente faz sentido para futuros (opções?)" ("Open interest is only available for futures"). Na interpretação do O/I, o manual ainda diz que "a informação do O/I é utilizada para mensurar a atividade e a força de um papel; um aumento no O/I, acompanhado de preços maiores, mostra que novos compradores continuam a entrar no mercado o que, portanto, pode ser visto como uma confirmação do movimento de alta; analogamente, uma diminuição no valor do O/I, enquanto os preços crescem (uma divergência) é, muitas vezes, vista como um sinal de alerta que sugere uma iminente baixa nos preços ("Open interest is used to measure the activity and strength of a commodity. An increase in open interest accompanied with higher prices shows that new buyers are continuing to enter the market and thus can be viewed as a confirmation of the upward price move. Likewise, a decrease in open interest while prices are making new highs (a divergence) is often viewed as a warning sign suggesting an impending decline in prices").

    Honestamente falando, eu, autor do Spero, não tenho certeza do que tudo isso, de fato, quer dizer e, na minha modesta opinião, não haveria informação disponível, no BDI, que pudesse atender à interpretação acima, logo, este campo deveria permanecer não utilizado. Entretanto, alguns usuários do Spero, certamente mais entendidos do que eu que sou apenas um programador, por compatibilidade com seus históricos montados com base em fornecedores de cotações, solicitaram que este campo fosse aproveitado para levar ao MetaStock uma dessas duas informações:

    • a informação do número de negócios do papel, contida no BDI. Tecnicamente falando, a informação do campo numérico 20, denominado TOTNEG - Número de Negócios Efetuados com o Papel-Mercado no Pregão Corrente, posições 174-178 do BDI não formatado da Bovespa; ou

    • a informação do número de distribuição do papel, contida no BDI. Tecnicamente falando, a informação do campo numérico 30, denominado DISMES - Número de Distribuição do Papel,, posições 278-280 do BDI não formatado da Bovespa.

    Para atender a esses usuários, foi criada esta opção. Se selecionada, no campo O/I do arquivo intermediário constará uma das informações mencionadas acima, dependendo da opção: TOTNEG ou DISMES. O campo O/I somente é repassado aos papéis negociados e não aos índices. É de total responsabilidade do usuário o uso opcional do campo O/I segundo as definições acima.

  • Preferências: neste grupo você tem as seguintes opções de operação do conversor Spero:

    (a)     mostrar ou não as dicas na barra de status, referentes aos diversos comandos (ou botões) contidos na janela principal do conversor Spero (quando se posiciona o cursor sobre eles);

    (b)     habilitar ou desabilitar a splash screen, ou seja, a tela de entrada do conversor Spero que surge, por alguns instantes, toda vez que o mesmo é acionado (e que corresponde ao diálogo Sobre);

    (c)     mostrar o título do programa Conversor Spero, na barra de título do aplicativo, com ou sem o caminho completo do diretório de trabalho, que corresponde ao diretório onde o conversor está instalado e onde a grande maioria das operações do mesmo são processadas.


Novidades desta Versão

A versão 0.99e não apresenta nenhum recurso novo, em relação à versão anterior (0.99d). A versão "e" corresponde à versão "d" porém comercializada; esta é a única diferença. De qualquer forma, segue uma rápida descrição dos principais novos melhoramentos introduzidos na versão "d".

  • o título do conversor pode ser reduzido a apenas "Conversor Spero";
  • a quantidade total de títulos negociados no índice Bovespa - Ibovespa - pode ser ajustada, considerando a divisão por mil de todos papéis negociados em lotes de mil;
  • a informação do número de negócios ou do número de distribuição pode ser repassada ao campo Open Interest;
  • a data do pregão pode ser retrocedida em 28 anos, possibilitando a utilizando dos programas MetaStock antigos, não compatíveis com o ano 2000;
  • a pasta de cotações no formato MetaStock deve ser passada ao DownLoader, quando da etapa de acionamente remoto;
  • o valor da indexação pode ser informado ao conversor no ato do processamento, ou seja, on the fly, facilitando o processamento de múltiplos arquivos, via Drag & Drop (arrastar e soltar);
  • a indexação pode, opcionalmente, atingir as cotações dos índices e/ou os volumes em quantidade de títulos;
  • para o mercado a termo, o ticker foi alterado em função dos diferentes prazos a que um mesmo papel pode estar sujeito.

Maiores detalhes sobre as novas características descritas acima você encontra ao longo deste manual do usuário.


Problemas Conhecidos do Conversor Spero

Não existe programa de computador sem bug, aqueles problemas que ocorrem em situações bastante específicas e que, na maioria das vezes, mas não em todas, não é sequer do conhecimento do programador. O conversor Spero, certamente, não foge à regra. Ele tem, nesta versão, alguns problemas já do meu conhecimento porém ainda não resolvidos, bugs que, sob determinadas condições, levam o conversor a agir de uma forma não apropriada.

O usuário pode-se perguntar porque disponibilizar um programa com problemas conhecidos e a resposta é que, embora se saiba da existência deles, ainda não foi encontrada uma solução satisfatória e não vale a pena deixar de disponibilizá-lo apenas por sua causa. Tratam-se de situações que podem ser evitadas, se o usuário as conhecer, e o tempo que provavelmente se levará para encontrar a solução não compensa a espera. São, até o momento, duas situações, descritas a seguir, e que vale a pena o usuário estar atento a elas, conhecê-las, saber como tentar evitá-las ou como lidar com elas.

1 Se você acionar a etapa de verificação de disponibilidade ou a de transferência do arquivo BDI da Bovespa sem estar conectado à Internet, o diálogo de "Conexão Dial-Up" será automaticamente chamado pelo conversor. Neste diálogo, você terá a opção de "Conectar-se" ou de "Cancelar" a operação de conexão. Se você cancelar a operação ou se a tentativa de conexão falhar, o conversor, obviamente, cancelará as tarefas programadas; entretanto, após isso ocorrer, se o usuário tentar novamente iniciar o processamento (ou seja, clicar no botão Processar), o conversor não mais chamará automaticamente o diálogo de "Conexão Dial-Up". Para conectar-se à Internet e o conversor poder acessar o servidor da Bovespa, o usuário deverá acionar o diálogo de "Conexão Dial-Up" manualmente; ou, numa segunda alternativa para desviar deste problema, basta o usuário fechar o conversor e acioná-lo novamente para que o processamento chame automaticamente o diálogo.

2 Algumas letras acentuadas não são possíveis de ser repassadas ao DownLoader, durante o seu acionamento remoto pelo Spero. Portanto, se esta etapa estiver selecionada, não utilize caracteres acentuados nos nomes (caminhos completos) dos diretórios de instalação do DownLoader e de armazenamento das suas cotações em formato MetaStock, sob pena de o acionamento remoto não ser bem sucedido.

Os bugs acima estão sendo estudados e podem estar resolvidos em uma próxima versão do conversor. Qualquer outra reação estranha do conversor que algum usuário venha a experimentar, seria de grande ajuda e eu ficaria grato se me fosse comunicada. Se você for reportar algum bug, peço que seja bastante claro quanto a descrever exatamente como aconteceu o problema. Fique à vontade para entrar em contato comigo, autor do conversor, utilizando o endereço eletrônico andre@viol.net.


Conversor SPERO versão 0.99e - comercial.
Copyright (C) 1998-2000 André Viol.
Todos os direitos reservados.

Leia com atenção os termos e condições estabelecidos a seguir. Este contrato aplica-se tão somente à versão de comercialização do programa Conversor Spero. Os termos e condições de uso da versão de demonstração estão estabelecidos ao final deste manual.

Este é um contrato de licença aplicável ao programa Conversor SPERO versão de comercialização, aqui denominado, simplesmente, CONVERSOR, realizado entre o interessado em utilizar o Conversor, aqui denominado, simplesmente, USUÁRIO, e o autor do Conversor, André Viol, aqui denominado, simplesmente, AUTOR.

O conversor não é um programa gratuito. O conversor é licenciado, e não vendido, ao usuário. O usuário interessado em utilizar o conversor poderá adquirir uma licença que lhe dará o direito de uso do mesmo, por um período determinado, podendo ser este de seis meses ou de doze meses.

Neste contrato, sempre que for mencionada a necessidade ou a opção de entrar em contato com o autor, o interessado ou usuário deve entender que deve ser utilizado, para tanto, o endereço andre@viol.net.

PREÇO DAS LICENÇAS

O valor da licença de uso do conversor SPERO é de R$ 20,00 (vinte reais), para a licença de uso de seis meses, ou de R$ 35,00 (trinta e cinco reais), para a licença de uso de doze meses. Entretanto, os valores mencionados podem sofrer alterações, nos centavos, para cima, podendo atingir até os valores MÁXIMOS de R$ 20,50 (vinte reais e cinqüenta centavos) e de R$ 35,50 (trinta e cinco reais e cinqüenta centavos), em função da necessidade de identificar o pagamento efetuado pelo interessado.

O interessado em adquirir uma licença de uso deverá, portanto, entrar em contato com o autor para receber as informações complementares necessárias para poder efetuar o pagamento.

FORMAS DE PAGAMENTO

No momento, existe apenas uma única forma de pagamento: via depósito bancário (DOC tradicional, DOC eletrônico - via Internet, depósito direto em uma agência do Banco do Brasil ou transferência eletrônica - via Internet, para quem tiver conta no BB) em conta-corrente do autor. APÓS A CONFIRMAÇÃO DO DEPÓSITO no EXATO valor informado pelo autor, referente ao tipo de licença solicitado (semestral ou anual), o novo usuário receberá, dentro do prazo contratual, o conversor, de acordo com as formas de envio estabelecidas mais adiante.

ACEITAÇÃO DESTE CONTRATO

O pagamento, por parte do usuário, do valor da licença desejada, implica, automaticamente, na total aceitação, por parte do usuário, de todas as condições estabelecidas neste contrato de licença. Se o interessado não concordar com quaisquer das condições aqui estabelecidas, não deve adquirir o conversor. O autor, no entanto, está aberto a discutir qualquer necessário melhoramento ou ajuste deste contrato de licença, podendo ser contatado, para este fim. Porém, qualquer alteração deste contrato será sempre a critério do autor e passará a ter validade apenas para as licenças adquiridas após a alteração; poderá também ter validade para os usuários antigos desde que estes entendam que as alterações lhes sejam benéficas.

CONTAGEM DO PRAZO DA LICENÇA

O prazo da licença de uso conta-se a partir do primeiro dia do mês seguinte ao que foi efetuado o pagamento da licença. No caso de renovação de licença, o prazo conta-se a partir do vencimento da licença anterior. Considera-se renovação de licença a aquisição de uma nova licença realizada até 31 (trinta e um) dias contados a partir do vencimento da licença anterior. Assim, apenas como exemplo hipotético, se o usuário adquirir uma licença de doze meses no dia 15 de agosto de 2000, ele poderá utilizar o conversor desde a data em que efetuar a transferência do mesmo para o seu computador até o dia 31 de agosto de 2001. Caso renove a licença até o dia 30 de setembro de 2001, sua nova licença lhe dará permissão de uso até o dia 31 de agosto de 2002. Caso adquira sua nova licença em outubro de 2001, esta não será mais considerada como renovação, mas sim como uma nova licença, que lhe dará permissão de uso até o dia 30 de outubro de 2002.

RENÚNCIA DE GARANTIA

O conversor e os arquivos que o acompanham são licenciados na forma como se encontram, ou seja, sem garantias quanto ao desempenho ou à aplicabilidade ou quaisquer garantias adicionais, sejam expressas ou implícitas. Em particular, não há garantia para a correta execução da etapa de acionamento remoto do programa The DownLoader, uma vez que o conversor apenas executa um programa externo que pode ter variações de uma versão para outra. Devido aos vários tipos de ambientes de "hardware" e "software" a que o conversor pode ser submetido, não se oferece nenhuma garantia de adaptabilidade para um propósito específico.

Dita a boa norma que o correto procedimento, ao se utilizar qualquer tipo de programa que lida com processamento de dados, é testar todos os seus recursos com dados não críticos, antes de acreditar no programa. O usuário deve assumir todo o risco de utilização do programa. Neste sentido, o autor coloca, à disposição de todos os interessados, o conversor versão demonstração o qual permite testar todas as capacidades do programa, limitando, apenas, a quantidade de dados processados. Qualquer obrigação do autor será limitada, exclusivamente, à reposição do produto ou restituição do valor de aquisição da licença de uso.

SUPORTE

O autor dará suporte à utilização do conversor por meio eletrônico, tão-somente, via endereço andre@viol.net. O suporte é gratuito para os usuários licenciados, ou seja, faz parte da licença de uso do conversor, porém restringe-se apenas à esclarecer dúvidas operacionais ou trocar idéias sobre melhoramentos do conversor, propriamente. Dúvidas sobre como operar o programa The DownLoader ou o programa MetaStock não fazem parte do suporte ao conversor. Uma vez que o conversor tem um relacionamento muito próximo com o programa The DownLoader, é importante que o usuário já tenha alguma familiaridade com a operação deste último, sem a qual fica comprometida a utilização do primeiro. Ressalte-se que o autor não dá e não dará suporte algum à utilização dos programas da Equis International, The DownLoader e MetaStock, mas apenas ao uso do conversor.

VERSÕES FUTURAS

O autor garante ao usuário que qualquer melhoramento introduzido no conversor ou, efetivamente, qualquer lançamento de novas versões do mesmo, ocorrido durante o período de validade da licença, será totalmente gratuito. O autor informará o usuário, por meio do seu endereço eletrônico cadastrado, a existência da nova versão e como proceder para obtê-la. Neste caso, o novo conversor terá sua validade igual a do conversor original.

PRAZO DE ENTREGA

Após a confirmação do pagamento da licença, o usuário receberá o conversor, ou instruções para a transferência do conversor, no prazo habitual de 24 (vinte e quatro) horas, podendo ser de, no máximo, 48 (quarenta e oito) horas. Eventualmente, por motivos de força maior, este prazo poderá ser dilatado; neste caso, o usuário será previamente informado, via seu endereço eletrônico cadastrado. Este prazo poderá ser totalmente comprometido caso o usuário não informe o autor sobre o pagamento, conforme item seguinte.

PAGAMENTO E AVISO

Os dados que complementam este tópico (e o tópico Dados Cadastrais, mais adiante) serão fornecidos somente àqueles interessados que enviarem mensagem ao autor solicitando as informações adicionais necessárias para que possam efetuar o pagamento da licença de uso.

Para efetuar o pagamento da licença, depositar o valor EXATO de:

R$ xx,xx (constará do complemento ao contrato enviado ao interessado)

na conta corrente: nº xxx.xxx-x (constará do complemento)
da agência : nº xxxx-x, (constará do complemento)
do Banco do Brasil - BB.

Após ter efetivado o pagamento, o autor solicita que, sem falta e o mais rápido que puder, seja-lhe enviada uma mensagem, informando-o da devida efetivação do pagamento. Não é necessário enviar nenhum comprovante do depósito ao autor, apenas informar - avisar - que o pagamento já foi realizado. Caso o usuário não informe o autor a respeito do pagamento, poderá haver grande atraso no prazo de entrega, tendo em vista que o autor somente verifica sua conta-corrente após ser avisado, via mensagem eletrônica, pelo usuário. É também muito importante que o usuário efetue o depósito no valor EXATO informado pelo autor, pois o valor dos centavos finais servirá para identificar o seu pagamento.

RECEBIMENTO DO CONVERSOR

Após ter confirmado o depósito do valor da licença, o autor enviará o conversor ao usuário, VIA INTERNET, utilizando o endereço cadastrado do mesmo. Caso o programa chegue ao usuário com algum problema de transmissão - arquivo corrompido, por exemplo - o usuário deverá informar o fato ao autor que providenciará novo envio.
Alternativamente, e a critério do autor, este poderá enviar ao usuário os dados necessários para que este proceda, ele próprio, à transferência do conversor para o seu computador. Neste caso, os dados serão um nome de identificação, uma senha e o endereço que deve ser digitado no navegador (Internet Explorer ou Netscape, por exemplo), para chamar o diálogo pertinente. Caso o usuário tenha dificuldade em efetuar a transferência, ele deve entrar em contato com o autor para que as providências necessárias possam ser tomadas.

FORMATOS DO CONVERSOR

O conversor pode ser enviado ao usuário no formato de arquivo de instalação - formato completo - ou no formato de arquivo de atualização - formato simplificado. O primeiro formato destina-se àqueles usuários que não instalaram, em seu computador, o programa de demonstração, pois ele contém todos os arquivos necessários para o correto funcionamento do conversor. O segundo formato destina-se aos usuários que, antes de adquirir a licença, instalaram previamente o conversor, versão demonstração, e, portanto, não precisam receber o arquivo completo mas apenas o arquivo "spero.exe", o qual deve ser simplesmente sobreposto ao arquivo, de mesmo nome, no diretório onde o conversor tiver sido instalado. Normalmente, a menos que solicitado explicitamente pelo usuário, o autor lhe enviará o conversor no formato SIMPLIFICADO, diminuindo assim o tráfego na Internet. Isto porque o autor entende que todo e qualquer usuário do conversor deva, antes de adquiri-lo, testá-lo, utilizando a versão de demonstração, para ter certeza do que está adquirindo. No entanto, em havendo a solicitação expressa do usuário, o autor enviará no formato completo. Ressalte-se que o conversor, em si, é exatamente o mesmo, seja na versão de instalação quanto na de atualização. Não há, em absoluto, nenhum prejuízo, para o usuário, em receber a versão de atualização, uma vez já tendo instalado a de demonstração.

DADOS CADASTRAIS

O seu endereço cadastrado será: "xxxxx@xxx.xxx.xx". (constará do complemento)
A sua licença de uso será válida até: "xx de xxxxx de 200x". (constará do complemento)
O seu nome cadastrado será: "xxxxxxx". (constará do complemento)

Qualquer alteração neste endereço deve ser comunicada ao autor, para que este proceda à devida atualização cadastral. É de inteira responsabilidade do usuário manter o autor informado do seu endereço eletrônico válido mais atual. O autor não se responsabiliza pelas conseqüências advindas de endereços eletrônicos inválidos a ele fornecidos, tendo em vista que tal ocorrência impossibilitará o contato mútuo entre as partes.
O autor fará uso do endereço cadastrado do usuário apenas nas comunicações entre ele e o usuário, comprometendo-se a não fornecer, sob hipótese alguma, este endereço a terceiros.

DIREITOS AUTORAIS

O conversor e os seus componentes são protegidos pela lei dos direitos autorais. Sua reprodução ou distribuição não autorizada, de seus componentes ou qualquer parte deles é uma violação legal e, acima de tudo, um desestímulo para que programadores independentes possam atender às necessidades específicas de processamento de dados, como no caso dos usuários do programa MetaStock, que necessitam de um programa de conversão específico, para poder trabalhar com os dados da Bovespa. Portanto, o autor do conversor, consciente da fragilidade de aplicação da lei dos direitos autorais, solicita a todos os usuários que pagaram por uma licença de uso do conversor, que não distribuam cópias do mesmo a terceiros pois o conversor é de uso privativo e exclusivo do usuário cadastrado.


Transferência do Arquivo de Instalação

A transferência do conversor Spero, versão de demonstração, deve ser feita a partir da página oficial, em http://www.viol.net/mucs. Todas as informações necessárias podem ser obtidas a partir deste endereço.

Quanto à versão comercial, conforme os termos do contrato, o interessado, após efetuar o respectivo pagamento, receberá o programa diretamente via correio eletrônico ou, alternativamente, receberá instruções de como efetuar a transferência.

André Viol
andre@viol.net


Utilização do Conversor SPERO

Após ter transferido o conversor Spero para o seu computador e tê-lo instalado, seguindo as instruções do tópico anterior, você está pronto para começar a utilizá-lo. Acione o conversor; você verá a sua janela principal, conforme mostra a fig. 2 (tópico seguinte).

Dica: as figuras mostradas neste manual do usuário podem ser visualizadas em uma janela em separado, para facilitar a leitura e compreensão das instruções aqui expostas, que muitas vezes remetem o texto para as figuras. Para ter acesso a esta janela em separado, basta clicar na parte da legenda da respectiva figura, sobre o texto "Fig. n", onde "n" representa o número da figura.

O primeiro ponto importante a saber diz respeito ao diretório de trabalho do conversor. Todo processamento efetuado pelo conversor Spero é feito a partir do diretório onde o mesmo foi instalado. Assim que você acionar o conversor pela primeira vez, ele mostrará, na legenda da barra de títulos, o nome seguido do diretório de trabalho. Exemplo: "Conversor Spero - C:\Arquivos de programas\Conversor Spero" (fig. 2).

Quando o conversor Spero for transferir automaticamente o arquivo BDI do site da Bovespa para o seu computador, será no diretório de trabalho que o BDI zipado será inicialmente armazenado; ao converter o BDI para o arquivo no formato "ASCII Text", será no diretório de trabalho que o conversor colocará o arquivo de saída (que tem extensão .PRN). A única exceção a essa regra é a operação de conversão múltipla via Drag & Drop, comentada em tópico específico, mais adiante.

Dica: se você for iniciante no uso do conversor, antes de utilizá-lo, pela primeira vez, para atualizar o diretório que contém suas cotações atuais no formato MetaStock, aconselha-se fazer um teste em um diretório especialmente criado para isso, temporário, direcionando a conversão do DownLoader para este diretório de teste e, posteriormente, analisando os resultados obtidos (utilizando o próprio DownLoader ou o MetaStock); com isso, você ganhará experiência com o conversor e, quando for efetuar a atualização real, poderá fazê-lo com segurança de que não estará, de alguma forma, comprometendo o formato atual dos seus dados. Alerte-se que se você atualizar suas cotações utilizando, por exemplo, um formato de ticker não compatível com seus dados atuais, será trabalhoso, posteriormente, limpar seu diretório de cotações (embora não seja difícil). Para alguns tipos de danos causado em suas cotações, um novo acionamento da conversão do DownLoader, utilizando o arquivo intermediário correto, poderá reparar o dano: o DownLoader, se corretamente configurado, automaticamente substitui as cotações existentes pelas novas, contidas no arquivo intermediário. Outra idéia é você fazer uma cópia de segurança do seu diretório de cotações, antes de se sentir seguro com o conversor.


O Conversor Spero está disponível em duas versões: de demonstração e de comercialização. Ambas as versões são qualitativamente idênticas, ou seja, ambas têm as mesmas funcionalidades e recursos operantes. Entretanto, elas têm objetivos diferentes. A versão de demonstração tem por objetivo permitir ao interessado, que ainda não conhece o conversor Spero, testá-lo, por completo, aprender como o conversor funciona, aprender o que cada etapa de processamento faz, a finalidade de cada ajuste de configuração, etc., a fim de decidir se o programa será útil ou não. A versão de demonstração do conversor pode ser transferida livremente para o computador do interessado, a partir do link disponível no site oficial do conversor. A versão de demonstração contém a palavra "demo" no diálogo "Sobre", enquanto a versão de comercialização contém, em lugar desta palavra, a data da validade licenciada do programa.

Após o interessado ter testado totalmente o conversor e ter atestado que ele atende às suas necessidades, ele poderá decidir adquirir uma licença de uso do conversor, versão de comercialização. Neste momento, o interessado deve ler todo o contrato de licença de uso e, em concordando com os seus termos, enviar uma mensagem ao autor do conversor.

Mas, afinal, qual é, então a diferença entre as versões de demonstração e de comercialização? Há duas diferenças apenas, porém fundamentais, entre as versões: a versão de demonstração (a) limita o número de papéis que podem ser processados (convertidos) a no máximo dez e (b) não converte os índices. Assim, quaisquer que sejam as opções selecionadas, o conversor converterá apenas os dez primeiros registros do arquivo BDI da Bovespa, que atendam às configurações, não incluindo, nestes dez registros, os dados dos índices (Ibovespa, IBX e IEE). Logo, no máximo dez papéis serão tratados. Estas limitações não existem na versão comercial.

Todas as informações necessárias para que o interessado possa adquirir uma licença de uso do Conversor SPERO constam do contrato. O contrato deve ser lido com atenção pois ele contém informações importantes que devem ser do conhecimento de qualquer um que esteja interessado em adquirir a licença.

Portanto, resumindo e complementando, se, após você ter: (a) TESTADO O CONVERSOR, utilizando a versão de demonstração, (b) ATESTADO que o conversor atende às suas necessidades, (c) LIDO todo o contrato de licença de uso, e (d) CONCORDADO com os seus termos, você tiver interessado em adquirir uma licença, favor entrar em contato com andre@viol.net para receber uma cópia personalizada do contrato, com os dados adicionais que lhe possibilitarão efetuar o devido pagamento e receber o programa. Não se esqueça de informar qual o tipo de licença desejada, se semestral ou anual; na ausência deste esclarecimento, será assumido que o interesse é pela licença anual.

É importante notar que o contrato tem como objetivo deixar claras as regras de relacionamento entre o autor e os usuários do Spero, tendo em vista que o conversor é um programa comercial. Pretende-se, com ele, deixar transparente até onde vai a obrigação de cada um, especialmente a obrigação do autor junto aos usuários. O contrato não precisará ser assinado por nenhuma das partes; o pagamento da licença, por parte do usuário, será suficiente para que o autor do programa tenha a certeza de que o usuário leu o contrato e concordou com o que está sendo oferecido a ele. Notem, no entanto, que não é objetivo do contrato "burocratizar" o relacionamento entre o autor e os usuários do Spero. O autor se coloca sempre à disposição dos interessados no Spero, adquirentes ou não da licença de uso, para trocar idéias e tentar ajudar - ou ser ajudado - naquilo que for possível.